Welcome to ShenZhenJia Knowledge Sharing Community for programmer and developer-Open, Learning and Share
menu search
person
Welcome To Ask or Share your Answers For Others

Categories

So we had the Discussion today in our company about +new Date() being good practice or not. Some prefer this way over new Date().getTime().

In my opinion, this is pretty convenient but on the other side one would say it's harder to read.

Are there any pros or cons besides the obvious "It's harder to understand for people not familiar with the unary operator"?

See Question&Answers more detail:os

与恶龙缠斗过久,自身亦成为恶龙;凝视深渊过久,深渊将回以凝视…
thumb_up_alt 0 like thumb_down_alt 0 dislike
133 views
Welcome To Ask or Share your Answers For Others

1 Answer

The getTime method appears to be a huge amount faster:

enter image description here

Why is this the case?

Here's what happens when you call the getTime method on a Date instance:

  1. Return the value of the [[PrimitiveValue]] internal property of this Date object.

Here's what happens when you apply the unary plus operator to a Date instance:

  1. Get the value of the Date instance in question
  2. Convert it to a Number
    1. Convert it to a primitive
      1. Call the internal [[DefaultValue]] method

与恶龙缠斗过久,自身亦成为恶龙;凝视深渊过久,深渊将回以凝视…
thumb_up_alt 0 like thumb_down_alt 0 dislike
Welcome to ShenZhenJia Knowledge Sharing Community for programmer and developer-Open, Learning and Share
...